summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/gnupg.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm43
1 files changed, 32 insertions, 11 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 6c103a4b36..9b00338178 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -418,6 +418,19 @@ and every application benefits from this.")
(properties '((ftp-server . "ftp.gnupg.org")
(ftp-directory . "/gcrypt/gpgme")))))
+;; TODO: Merge with gpgme in the next rebuild cycle.
+(define-public gpgme-1.18
+ (package
+ (inherit gpgme)
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnupg/gpgme/gpgme-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "17hfigfnq6xz45b5xrp299f68b5mwx0aysd51sx5v4nf8yp4w79n"))))))
+
(define-public qgpgme
(package
(inherit gpgme)
@@ -446,10 +459,20 @@ QGpgME was originally developed as part of libkleo and incorporated into
gpgpme starting with version 1.7.")
(license license:gpl2+))) ;; Note: this differs from gpgme
+;; TODO: Merge with qgpgme in the next rebuild cycle.
+(define-public qgpgme-1.18
+ (package
+ (inherit qgpgme)
+ (version (package-version gpgme-1.18))
+ (source (package-source gpgme-1.18))
+ (inputs
+ (modify-inputs (package-inputs qgpgme)
+ (replace "gpgme" gpgme-1.18)))))
+
(define-public guile-gcrypt
(package
(name "guile-gcrypt")
- (version "0.3.0")
+ (version "0.4.0")
(home-page "https://notabug.org/cwebber/guile-gcrypt")
(source (origin
(method git-fetch)
@@ -458,7 +481,7 @@ gpgpme starting with version 1.7.")
(commit (string-append "v" version))))
(sha256
(base32
- "0m29fg4pdfifnqqsa437zc5c1bhbfh62mc69ba25ak4x2cla41ll"))
+ "0m75h9q10yb27kzjsvhhq0yk3jaxiy9bpbfd9qg269hf9gabgfdx"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -790,14 +813,14 @@ including tools for signing keys, keyring analysis, and party preparation.
(define-public pinentry-tty
(package
(name "pinentry-tty")
- (version "1.2.0")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/pinentry/pinentry-"
version ".tar.bz2"))
(sha256
(base32
- "0w34c4x5hkxaxnnkcrm1azlzwzxcziv5dkci3xcd0hz0ld2j01qh"))))
+ "0rs019acfj7sr4pvc847nk42v5mba9ixqmd98nwqy8w5b9g1hyj5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--enable-pinentry-tty")))
@@ -1154,7 +1177,7 @@ over.")
(define-public jetring
(package
(name "jetring")
- (version "0.30")
+ (version "0.31")
(source
(origin
(method git-fetch)
@@ -1168,14 +1191,13 @@ over.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
+ (delete 'configure) ; no configure script
(add-before 'install 'hardlink-gnupg
(lambda* (#:key inputs #:allow-other-keys)
(let ((gpg (search-input-file inputs "/bin/gpg")))
(substitute* (find-files "." "jetring-[[:alpha:]]+$")
(("gpg -") (string-append gpg " -"))
- (("\\\"gpg\\\"") (string-append "\"" gpg "\"")))
- #t)))
+ (("\\\"gpg\\\"") (string-append "\"" gpg "\""))))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1186,9 +1208,8 @@ over.")
(for-each (lambda (file)
(install-file file (string-append man "/man1/")))
(find-files "." ".*\\.1$"))
- (install-file "jetring.7" (string-append man "/man7/"))
- #t))))
- #:tests? #f)) ; no test phase
+ (install-file "jetring.7" (string-append man "/man7/"))))))
+ #:tests? #f)) ; no tests
(inputs
(list gnupg perl))
(home-page "https://joeyh.name/code/jetring/")