summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-19 22:01:03 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-20 10:30:05 +0100
commitcd064df7bbc554ab1cb1d5aeea9323e22f7b65f5 (patch)
treee3dafb79fc7f37bc93cfd1406c0cf412a55ea737 /gnu/packages/gnupg.scm
parent232010f89dc6f9fc6f8a1ca5df846048c9eff8ef (diff)
gnu: gnupg: Add version 2.1.2.
* gnu/packages/gnupg.scm (gnupg): Update to 2.1.2. (gnupg-2.0): Copy of previous package for version 2.0.26.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm40
1 files changed, 35 insertions, 5 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index a7b303bcaa..584b1c68c1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -190,14 +190,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.0.26")
+ (version "2.1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1q5qcl5panrvcvpwvz6nl9gayl5a6vwvfhgdcxqpmbl2qc6y6n3p"))))
+ "14k7c5spai3yppz6izf1ggbnffskl54ln87v1wgy9pwism1mlks0"))))
(build-system gnu-build-system)
(inputs
`(("bzip2" ,guix:bzip2)
@@ -206,7 +206,7 @@ compatible to GNU Pth.")
("libgcrypt" ,libgcrypt)
("libgpg-error" ,libgpg-error)
("libksba" ,libksba)
- ("pth" ,pth)
+ ("npth" ,npth)
("openldap" ,openldap)
("zlib" ,guix:zlib)
("readline" ,readline)))
@@ -215,8 +215,8 @@ compatible to GNU Pth.")
(alist-cons-before
'configure 'patch-config-files
(lambda _
- (substitute* "tests/openpgp/Makefile.in"
- (("/bin/sh") (which "bash"))))
+ (substitute* "tests/openpgp/defs.inc"
+ (("/bin/pwd") (which "pwd"))))
%standard-phases)))
(home-page "http://gnupg.org/")
(synopsis "GNU Privacy Guard")
@@ -229,6 +229,36 @@ components), libgpg-error (centralized GnuPG error values), and
libskba (working with X.509 certificates and CMS data).")
(license gpl3+)))
+(define-public gnupg-2.0
+ (package (inherit gnupg)
+ (version "2.0.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1q5qcl5panrvcvpwvz6nl9gayl5a6vwvfhgdcxqpmbl2qc6y6n3p"))))
+ (inputs
+ `(("bzip2" ,guix:bzip2)
+ ("curl" ,curl)
+ ("libassuan" ,libassuan)
+ ("libgcrypt" ,libgcrypt)
+ ("libgpg-error" ,libgpg-error)
+ ("libksba" ,libksba)
+ ("pth" ,pth)
+ ("openldap" ,openldap)
+ ("zlib" ,guix:zlib)
+ ("readline" ,readline)))
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'configure 'patch-config-files
+ (lambda _
+ (substitute* "tests/openpgp/Makefile.in"
+ (("/bin/sh") (which "bash"))))
+ %standard-phases)))))
+
(define-public gnupg-1
(package (inherit gnupg)
(version "1.4.18")