summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-02 15:21:15 -0500
committerLeo Famulari <leo@famulari.name>2017-01-03 12:35:44 -0500
commite3dd1f0cb8b0aaca5665e9c5450354b8cda8a5cf (patch)
tree655e8144b3f053d8d1b46830cb17c7149cb44729 /gnu/packages/gnupg.scm
parent9e0f16f23f421fe8e310e2feb654267218394be8 (diff)
gnu: Add python-gpg.
* gnu/packages/gnupg.scm (python-gpg, python2-gpg): New variable.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4a7b323b43..56fba45e3a 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages security-token)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages tls)
#:use-module (guix packages)
#:use-module (guix download)
@@ -382,6 +384,33 @@ instead. This way bug fixes or improvements can be done at a central place
and every application benefits from this.")
(license license:lgpl2.1+)))
+(define-public python-gpg
+ (package
+ (name "python-gpg")
+ (version (package-version gpgme))
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gpg" version))
+ (sha256
+ (base32
+ "1x74i6q713c0bckls7rdm8kgsmllf9qvy9x62jghszlhgjkyh9nd"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; No test suite.
+ (inputs
+ `(("gpgme" ,gpgme)))
+ (native-inputs
+ `(("swig" ,swig)))
+ (home-page (package-home-page gpgme))
+ (synopsis "Python bindings for GPGME GnuPG cryptography library")
+ (description "This package provides Python bindings to the GPGME GnuPG
+cryptographic library. It is developed in the GPGME source code, and then
+distributed separately.")
+ (license license:lgpl2.1+)))
+
+(define-public python2-gpg
+ (package-with-python2 python-gpg))
+
(define-public python-pygpgme
(package
(name "python-pygpgme")