summaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorJessica Tallon <tsyesika@tsyesika.se>2022-08-26 22:06:20 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:17:14 +0200
commitaae98c297214f87eb45302863adb021078c41a6f (patch)
tree9375ad1f563adfdedbe60181ba5cd88b2dccb355 /gnu/packages/gnustep.scm
parent9c5a952818d4780ae62f0cd1e413fd611f4adf24 (diff)
gnu: Add wmamixer.
* gnu/packages/gnustep.scm (wmamixer): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index ba7060504c..a6f9b0e2fb 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages autotools)
@@ -335,3 +336,37 @@ entering the dock a burning spot replaces the cursor, and after two seconds
symbols to represent the current monitor are \"burnt\" onscreen. The flame
colour can also be changed.")
(license license:gpl2+)))
+
+(define-public wmamixer
+ (package
+ (name "wmamixer")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gryf/wmamixer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04vv4kr4mj1nwri6zqgdg4yzbbmmng73qd4h0azliril75m7sldf"))))
+ (inputs (list libx11 libxpm libxext alsa-lib))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "wmamixer" bin)))))))
+ (synopsis "Window maker applet to display the current volume")
+ (description
+ "wmamixer is an applet for window maker which displays the
+current volume level both numerically and visiaully with a volume bar. It
+includes the ability to toggle through different outputs to show their
+respective volume level.")
+ (home-page "https://github.com/gryf/wmamixer")
+ (license license:gpl2+)))
+