summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-12-20 14:40:24 +0100
committerClément Lassieur <clement@lassieur.org>2024-01-04 23:47:15 +0100
commitbe1d05c10766a979dd0720b677889ed950d3b895 (patch)
tree22665f79ffcce446405eb9668caec445a233e483 /gnu/packages/gnuzilla.scm
parent9816a5371663396bc092eb359222635e5675b174 (diff)
gnu: icecat-minimal: Fix WM Class.
* gnu/packages/gnuzilla.scm (icecat-minimal)[arguments]: Set the MOZ_APP_REMOTINGNAME environment variable and replace "Navigator" with "Icecat" in icecat.desktop. The WM Class should be "Navigator, Icecat" instead of "Navigator, icecat-default". StartupWMClass in icecat.desktop should be "Icecat" instead of "Navigator" so that other browsers (they often have the "Navigator" class) won't be associated with Icecat. Change-Id: I57bec957938c56e8acf9cd5c955e57dbad081678
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index bf9bf34e3a..188aa02293 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1034,6 +1034,9 @@ variable defined below. It requires guile-json to be installed."
(setenv "MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE" "system")
(setenv "MOZ_BUILD_DATE" #$%icecat-build-id) ; avoid timestamp
+ ;; WM_CLASS (default is "$MOZ_APP_NAME-$MOZ_UPDATE_CHANNEL").
+ (setenv "MOZ_APP_REMOTINGNAME" "Icecat")
+
;; XXX TODO: Fix this to work on systems other than x86_64-linux.
(setenv "GUIX_PYTHONPATH"
(string-append (getcwd)
@@ -1126,7 +1129,7 @@ variable defined below. It requires guile-json to be installed."
(("NewWindow") "new-window")
(("NewPrivateWindow") "new-private-window")
(("StartupNotify=true")
- "StartupNotify=true\nStartupWMClass=Navigator"))
+ "StartupNotify=true\nStartupWMClass=Icecat"))
(install-file desktop-file applications))))
(add-after 'install-desktop-entry 'install-icons
(lambda _