summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-27 16:19:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-03-28 09:34:53 +0300
commita64b7da5133b1b0f70ba873cab9b3bebfd84a58e (patch)
tree0cc74abde1eab4cf98ef90f6e2c7f4bd6ef4b599 /gnu/packages/gnuzilla.scm
parent26f38d313bd4ccece05610f762612daa0746dd44 (diff)
gnu: mozjs@17: Add support for aarch64-linux.
* gnu/packages/gnuzilla.scm (mozjs@17)[source]: Add patch. [arguments]: Add phase deleting slow test, add configure argument for building on aarch64-linux. * gnu/packages/patches/mozjs17-aarch64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5c892f197a..2586cf60f4 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -69,6 +69,7 @@
(sha256
(base32
"1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))
+ (patches (search-patches "mozjs17-aarch64-support.patch"))
(modules '((guix build utils)))
(snippet
;; Fix incompatibility with Perl 5.22+.
@@ -83,6 +84,9 @@
;; mkdir -p "system_wrapper_js/"
#:parallel-build? #f
#:phases
+ (alist-cons-after 'unpack 'delete-timedout-test
+ ;; This test times out on slower hardware.
+ (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js"))
(alist-cons-before
'configure 'chdir
(lambda _
@@ -95,8 +99,12 @@
(setenv "SHELL" (which "sh"))
(setenv "CONFIG_SHELL" (which "sh"))
(zero? (system*
- "./configure" (string-append "--prefix=" out)))))
- %standard-phases))))
+ "./configure" (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())))))
+ %standard-phases)))))
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
(synopsis "Mozilla javascript engine")