summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-11 09:38:49 -0500
committerMark H Weaver <mhw@netris.org>2015-01-11 09:38:49 -0500
commit77448857311318fc9cd866afcb85ca98fccdb25b (patch)
treeefed3a71d1f7b2c2cc292e7e4ba1884c4d26a9e4 /gnu/packages/gnuzilla.scm
parent62c155c0bcbc0d71b1bc35e966193b6e8de03246 (diff)
parent0009ed71ad288358cbc7828954b5e1a3f18fd525 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm168
1 files changed, 168 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 3ebc20dffa..8e397464ac 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages glib)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -42,6 +44,172 @@
#:use-module (gnu packages yasm)
#:use-module (gnu packages zip))
+(define-public mozjs
+ (package
+ (name "mozjs")
+ (version "17.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ftp.mozilla.org/pub/mozilla.org/js/"
+ name version ".tar.gz"))
+ (sha256
+ (base32
+ "1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl", perl)
+ ("python" ,python-2)))
+ (arguments
+ `(#:phases
+ (alist-cons-before
+ 'configure 'chdir
+ (lambda _
+ (chdir "js/src"))
+ (alist-replace
+ 'configure
+ ;; configure fails if it is followed by SHELL and CONFIG_SHELL
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (zero? (system*
+ "./configure" (string-append "--prefix=" out)))))
+ %standard-phases))))
+ (home-page
+ "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
+ (synopsis "Mozilla javascript engine")
+ (description "SpiderMonkey is Mozilla's JavaScript engine written
+in C/C++.")
+ (license license:mpl2.0))) ; and others for some files
+
+(define-public nspr
+ (package
+ (name "nspr")
+ (version "4.10.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v"
+ version "/src/nspr-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0f1ri51yzjikigf6z31g03cdv6sgi9gw2c3vvv39psk3m37zb6iq"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl", perl)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:configure-flags
+ `("--enable-64bit")
+ #:phases
+ (alist-cons-before
+ 'configure 'chdir
+ (lambda _
+ (chdir "nspr"))
+ %standard-phases)))
+ (home-page
+ "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR")
+ (synopsis "Netscape API for system level and libc-like functions")
+ (description "Netscape Portable Runtime (NSPR) provides a
+platform-neutral API for system level and libc-like functions. It is used
+in the Mozilla clients.")
+ (license license:mpl2.0)))
+
+(define-public nss
+ (package
+ (name "nss")
+ (version "3.17.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/"
+ "releases/NSS_3_17_3_RTM/src/nss-3.17.3.tar.gz"))
+ (sha256
+ (base32
+ "1m91z80x4zh1mxgf53bl33lp43gn1wxxx0y26mgz511gb81ykmgl"))
+ ;; Create nss.pc and nss-config.
+ (patches (list (search-patch "nss-pkgconfig.patch")))))
+ (build-system gnu-build-system)
+ (outputs '("out" "bin"))
+ (arguments
+ '(#:parallel-build? #f ; failed
+ #:make-flags
+ (let* ((out (assoc-ref %outputs "out"))
+ (nspr (string-append (assoc-ref %build-inputs "nspr")))
+ (rpath (string-append "-Wl,-rpath=" out "/lib/nss")))
+ (list "-C" "nss" (string-append "PREFIX=" out)
+ "NSDISTMODE=copy"
+ "NSS_USE_SYSTEM_SQLITE=1"
+ (string-append "NSPR_INCLUDE_DIR=" nspr "/include/nspr")
+ ;; Add $out/lib/nss to RPATH.
+ (string-append "RPATH=" rpath)
+ (string-append "LDFLAGS=" rpath)))
+ #:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 ftw)
+ (ice-9 match)
+ (srfi srfi-26))
+ #:imported-modules ((guix build gnu-build-system)
+ (guix build utils))
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key system inputs #:allow-other-keys)
+ ;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
+ (when (string-prefix? "x86_64" system)
+ (setenv "USE_64" "1"))
+ #t)
+ (alist-replace
+ 'check
+ (lambda _
+ ;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
+ ;; The later requires a working DNS or /etc/hosts.
+ (setenv "DOMSUF" "(none)")
+ (setenv "USE_IP" "TRUE")
+ (setenv "IP_ADDRESS" "127.0.0.1")
+ (zero? (system* "./nss/tests/all.sh")))
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append (assoc-ref outputs "bin") "/bin"))
+ (inc (string-append out "/include/nss"))
+ (lib (string-append out "/lib/nss"))
+ (obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
+ ((obj) (string-append "dist/" obj)))))
+ ;; Install nss-config to $out/bin.
+ (mkdir-p (string-append out "/bin"))
+ (copy-file (string-append obj "/bin/nss-config")
+ (string-append out "/bin/nss-config"))
+ (delete-file (string-append obj "/bin/nss-config"))
+ ;; Install nss.pc to $out/lib/pkgconfig.
+ (mkdir-p (string-append out "/lib/pkgconfig"))
+ (copy-file (string-append obj "/lib/pkgconfig/nss.pc")
+ (string-append out "/lib/pkgconfig/nss.pc"))
+ (delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
+ (rmdir (string-append obj "/lib/pkgconfig"))
+ ;; Install other files.
+ (copy-recursively "dist/public/nss" inc)
+ (copy-recursively (string-append obj "/bin") bin)
+ (copy-recursively (string-append obj "/lib") lib)))
+ %standard-phases)))))
+ (inputs
+ `(("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
+ (native-inputs `(("perl" ,perl)))
+ (home-page
+ "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
+ (synopsis "Network Security Services")
+ (description
+ "Network Security Services (NSS) is a set of libraries designed to support
+cross-platform development of security-enabled client and server applications.
+Applications built with NSS can support SSL v2 and v3, TLS, PKCS #5, PKCS #7,
+PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other security
+standards.")
+ (license license:mpl2.0)))
+
(define-public icecat
(package
(name "icecat")