summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-04-27 22:04:05 -0400
committerMark H Weaver <mhw@netris.org>2016-04-28 10:25:18 -0400
commit3161f6a4eca3225778a76eb5c21cfc150e6dce0a (patch)
treedb563391ecb37cd811fe058e2fbd6e282da0f131 /gnu/packages/gnuzilla.scm
parentb3107888aa448d9441cb4ee17dcba784beb2405c (diff)
gnu: nss: Update to 3.23.
* gnu/packages/gnuzilla.scm (nss): Update to 3.23. [arguments]: In the 'install' phase, remove libgtest1.so from the output.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index f8c3b6ebc9..e774ed1ad2 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -178,7 +178,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.21.1")
+ (version "3.23")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -189,7 +189,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "0knr99yc8sba2ga6x1gwhg9gr1dmgcl344g3bmxm8c364i2vpxns"))
+ "1kqidv91icq96m9m8zx50n7px08km2l88458rkgyjwcn3kiq7cwl"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"))))
(build-system gnu-build-system)
@@ -251,7 +251,16 @@ in the Mozilla clients.")
;; Install other files.
(copy-recursively "dist/public/nss" inc)
(copy-recursively (string-append obj "/bin") bin)
- (copy-recursively (string-append obj "/lib") lib)))
+ (copy-recursively (string-append obj "/lib") lib)
+
+ ;; FIXME: libgtest1.so is installed in the above step, and it's
+ ;; (unnecessarily) linked with several NSS libraries, but
+ ;; without the needed rpaths, causing the 'validate-runpath'
+ ;; phase to fail. Here we simply delete libgtest1.so, since it
+ ;; seems to be used only during the tests.
+ (delete-file (string-append lib "/libgtest1.so"))
+
+ #t))
%standard-phases)))))
(inputs
`(("sqlite" ,sqlite)