summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-10 08:40:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-10 08:40:42 +0300
commit58e87f66ceb619c44d486361ebf0f608abe63f5d (patch)
treeae6fa4b87dceef143d8e21f151e576467db4b144 /gnu/packages/gnuzilla.scm
parent9c45c51992bbb499c5f03cd1c9285937e8b2a00f (diff)
gnu: icecat: Update to 38.7.1-gnu1.
* gnu/packages/gnuzilla.scm (icecat): Update to 38.7.1-gnu1. [sources]: Remove numerous patches. * gnu/packages/patches/icecat-CVE-2015-4477.patch, gnu/packages/patches/icecat-CVE-2015-7207.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1952-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1954.patch, gnu/packages/patches/icecat-CVE-2016-1960.patch, gnu/packages/patches/icecat-CVE-2016-1961.patch, gnu/packages/patches/icecat-CVE-2016-1962.patch, gnu/packages/patches/icecat-CVE-2016-1964.patch, gnu/packages/patches/icecat-CVE-2016-1965.patch, gnu/packages/patches/icecat-CVE-2016-1966.patch, gnu/packages/patches/icecat-CVE-2016-1974.patch, gnu/packages/patches/icecat-icecatbug-1248851.patch, gnu/packages/patches/icecat-update-graphite2.patch, gnu/packages/patches/icecat-update-graphite2-pt2.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm26
1 files changed, 4 insertions, 22 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b4892d77cd..1ae97b256b 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -277,7 +278,7 @@ standards.")
(define-public icecat
(package
(name "icecat")
- (version "38.6.0-gnu1")
+ (version "38.7.1-gnu1")
(source
(origin
(method url-fetch)
@@ -286,29 +287,10 @@ standards.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0bd4k5cwr8ynscaxffvj2x3kgky3dmjq0qhpcb931l98bh0103lx"))
+ "1wdmd6hasra36g86ha1dw8sl7a5mvr7c4jbjx4zyg9629y5gqr8g"))
(patches (map search-patch
'("icecat-avoid-bundled-includes.patch"
- "icecat-re-enable-DHE-cipher-suites.patch"
- "icecat-update-graphite2.patch"
- "icecat-update-graphite2-pt2.patch"
- "icecat-CVE-2015-4477.patch"
- "icecat-CVE-2015-7207.patch"
- "icecat-CVE-2016-1952-pt01.patch"
- "icecat-CVE-2016-1952-pt02.patch"
- "icecat-CVE-2016-1952-pt03.patch"
- "icecat-CVE-2016-1952-pt04.patch"
- "icecat-CVE-2016-1952-pt05.patch"
- "icecat-CVE-2016-1952-pt06.patch"
- "icecat-CVE-2016-1954.patch"
- "icecat-CVE-2016-1960.patch"
- "icecat-CVE-2016-1961.patch"
- "icecat-CVE-2016-1962.patch"
- "icecat-CVE-2016-1964.patch"
- "icecat-CVE-2016-1965.patch"
- "icecat-CVE-2016-1966.patch"
- "icecat-CVE-2016-1974.patch"
- "icecat-bug-1248851.patch")))
+ "icecat-re-enable-DHE-cipher-suites.patch")))
(modules '((guix build utils)))
(snippet
'(begin