summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-22 01:09:14 +0200
committerMarius Bakke <marius@gnu.org>2022-07-22 01:09:14 +0200
commit9044b086ddca64a62966a83cbf1b82d32dece89e (patch)
tree2c7f910c9100b2f2a752d07fe0ec44be83fb7600 /gnu/packages/gnuzilla.scm
parent5dfc6ab1ab292b87ceea144aa661d0e64c834031 (diff)
parentabea091dbef2d44e6eb46bd2413bdf917e14d095 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 09a7d7c581..1c82bbe553 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -127,10 +127,6 @@
"--enable-hardening"
"--enable-optimize"
"--enable-release"
- ;; FIXME: rust-simd is disabled otherwise the build fails with
- ;; "error: `[u32; 64]` is forbidden as the type of a const generic
- ;; parameter".
- "--disable-rust-simd"
"--enable-readline"
"--enable-shared-js"
"--with-system-icu"
@@ -225,8 +221,7 @@
(native-inputs
(list autoconf-2.13
automake
- ;; TODO(staging): Use the default LLVM in the next rebuild cycle.
- llvm-9 ;for llvm-objdump
+ llvm ;for llvm-objdump
perl
pkg-config
python-3
@@ -372,8 +367,8 @@ in C/C++.")
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-version "91.10.0-guix0-preview1")
-(define %icecat-build-id "20220531000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-version "91.11.0-guix0-preview1")
+(define %icecat-build-id "20220628000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -395,11 +390,11 @@ in C/C++.")
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "1fz11rmbb0qjcp84wz7hmq7wy1zh9bk6vk47xwhrinmmifrqqnl2"))))
+ "1905595fsydd8q4bqxsp5gb4h9s47qjj90wjrqv4ky8yxs9bx6z5"))))
- (upstream-icecat-base-version "91.10.0") ; maybe older than base-version
+ (upstream-icecat-base-version "91.11.0") ; maybe older than base-version
;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
- (gnuzilla-commit "4c39c619daf344f36962d958d809f6d42d3fce4e")
+ (gnuzilla-commit "65a61287a5142a9403ec00d973cb5e5d658a3c71")
(gnuzilla-source
(origin
(method git-fetch)
@@ -411,7 +406,7 @@ in C/C++.")
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "1fizsq0dphm40nj6vnvjp87v34iyg78gllv3jp5ssn43ln4jiyb7"))))
+ "02mg7vg0bv5lxkdg86z18mf43rx7sh5i2w69lnirr8zqcrr5yd48"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.
@@ -978,11 +973,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220531000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220624000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.10.0")
+ (version "91.11.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1261,7 +1256,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "4a4b901410a9055d078d0cdd7c62b2b5d56ffbad"))
+ ,(let ((changeset "da48e7ecf800ec7761a3b6e0ca81e0c90adc30f7"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1270,7 +1265,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "0i2wpi08jfksqqc0j6q362nyk3zmlqd5ds2w7mm74infvrw6fzzq")))))
+ "0lg8z0zk05w8jah364lm7vkc95j1nkg93gf46byz0kd4nslg05nx")))))
("cargo" ,rust "cargo")
("clang" ,clang)
("llvm" ,llvm)