summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-30 23:47:25 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-03-31 00:45:47 +0200
commitcb0ae06d76ebb08e48c1a4f39e81f0be93013075 (patch)
treec0b99f412b71a6ab9e953d2c9e200340530a45e4 /gnu/packages/gnuzilla.scm
parente7558d16479158f893bca7c295986c08c151caa9 (diff)
gnu: icedove: Update to 102.9.1 [fixes CVE-2023-28427].
* gnu/packages/gnuzilla.scm (%icedove-version): Update to 102.9.1. (%icedove-build-id, thunderbird-comm-l10n): Update accordingly.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 253b8c285c..7d0860469f 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1117,8 +1117,8 @@ standards of the IceCat project.")
"ru" "sco" "si" "sk" "sl" "son" "sq" "sr" "sv-SE" "szl" "ta" "te" "th" "tl"
"tr" "trs" "uk" "ur" "uz" "vi" "xh" "zh-CN" "zh-TW"))
-(define %icedove-build-id "20230314000000") ;must be of the form YYYYMMDDhhmmss
-(define %icedove-version "102.9.0")
+(define %icedove-build-id "20230328000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-version "102.9.1")
;; Provides the "comm" folder which is inserted into the icecat source.
;; Avoids the duplication of Icecat's source tarball.
@@ -1127,11 +1127,11 @@ standards of the IceCat project.")
(method hg-fetch)
(uri (hg-reference
(url "https://hg.mozilla.org/releases/comm-esr102")
- (changeset "db735c436e680abf21cc67f9a29b42fdf30d416d")))
+ (changeset "a8965ef0b30705f497df3df718db60d9dc2c304f")))
(file-name (string-append "thunderbird-" %icedove-version "-checkout"))
(sha256
(base32
- "114vvwlrmjilczwsg9nfcg08560vijlydw1pdrbkvxjbfgsxny71"))))
+ "14lj30a9hmiwxpriyfls245y1wj2j3hfwrsbf7s5d9ligjqldjag"))))
(define (comm-source->locales+changeset source)
"Given SOURCE, a checkout of the Thunderbird 'comm' component, return the