summaryrefslogtreecommitdiff
path: root/gnu/packages/gobby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:39:52 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-13 23:45:53 -0500
commit01f0707207741ce2a5d7509a175464799b08aea6 (patch)
tree08e8f4da56f26363c3b53e0442a21b286b55e0e5 /gnu/packages/gobby.scm
parent734bcf13139119daf8685f93b056c3422dbfa264 (diff)
parent6985a1acb3e9cc4cad8b6f63d77154842d25c929 (diff)
Merge branch 'staging' into 'core-updates'.
Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/gobby.scm')
-rw-r--r--gnu/packages/gobby.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
index 91484c7576..0e1910d7ce 100644
--- a/gnu/packages/gobby.scm
+++ b/gnu/packages/gobby.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +49,9 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--disable-static")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'update-gnutls-api
(lambda _
@@ -80,6 +84,9 @@
(base32
"0rwvp0kzsb8y6mq73rzb8yk4kvsrz64i2zf4lfqs3kh0x2k7n7bx"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-static")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -177,7 +184,7 @@ together over the internet in real-time.")
(define-public libinfinity
(package
(name "libinfinity")
- (version "0.7.1")
+ (version "0.7.2")
(source
(origin
(method url-fetch)
@@ -185,7 +192,7 @@ together over the internet in real-time.")
version ".tar.gz"))
(sha256
(base32
- "1jw2fhrcbpyz99bij07iyhy9ffyqdn87vl8cb1qz897y3f2f0vk2"))))
+ "17i3g61hxz9pzl3ryd1yr15142r25m06jfzjrpdy7ic1b8vjjw3f"))))
(build-system gnu-build-system)
(inputs
`(("glib" ,glib)
@@ -195,7 +202,8 @@ together over the internet in real-time.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(#:configure-flags (list "--with-inftextgtk"
+ `(#:configure-flags (list "--disable-static"
+ "--with-inftextgtk"
"--with-infgtk")))
(home-page "https://gobby.github.io/")
(synopsis "Infininote protocol implementation")