summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-01-27 19:21:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-31 21:20:17 +0000
commit6d5fe89e8ef385485ee84ceae178be8e7135fa7c (patch)
treef8ce9f2d181d0f32af0a0c58130e9bd961a8e8cd /gnu/packages/golang-check.scm
parenteab88f2e458035560310f5dd2be92ee47183f8b9 (diff)
gnu: Add go-keyify.
* gnu/packages/golang-check.scm (go-keyify): New variable. Change-Id: I99d41a18cb0e00dd35bef9c2c8fce12748f24ad4 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b9dd235cc2..ae496affd0 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -84,6 +84,18 @@ Using static analysis, it finds bugs and performance issues, offers
simplifications, and enforces style rules.")
(license license:expat)))
+(define-public go-keyify
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-keyify")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/keyify"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Transform an unkeyed struct literal into a keyed one in Go")
+ (description "This package turns unkeyed struct literals (@code{T{1, 2,
+3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))