summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
commit7bf4ce4582cd2f9c5b30c547262c1c4a426c0b9b (patch)
treec6f9cc83feaaf685b7542a98e60bc24ea7c297b1 /gnu/packages/golang-check.scm
parent06d01c610e3bee61e38a177aecda5982d5b338ae (diff)
parent92d8b4c9598ed32cdb6630433d5914c1ae8b7146 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm122
1 files changed, 92 insertions, 30 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 8ce85421e9..aaa2de33a6 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,39 +60,35 @@
;;; Libraries:
;;;
-(define-public go-github-com-alecthomas-assert
- (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
- (revision "1"))
- (package
- (name "go-github-com-alecthomas-assert")
- (version (git-version "0.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/assert")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1l567pi17k593nrd1qlbmiq8z9jy3qs60px2a16fdpzjsizwqx8l"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/alecthomas/assert"))
- (native-inputs
- (list go-github-com-alecthomas-colour
- go-github-com-mattn-go-isatty
- go-github-com-alecthomas-repr
- go-github-com-sergi-go-diff))
- (home-page "https://github.com/alecthomas/assert/")
- (synopsis "Go assertion library")
- (description "Assertion library that:
+(define-public go-github-com-alecthomas-assert-v2
+ (package
+ (name "go-github-com-alecthomas-assert-v2")
+ (version "2.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ai26ncfcwzg47rqaigs5v1fzfz6i8p11ki75ni5429xkjs77riz"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:go go-1.18
+ #:import-path "github.com/alecthomas/assert/v2"))
+ (propagated-inputs
+ (list go-github-com-alecthomas-repr
+ go-github-com-hexops-gotextdiff))
+ (home-page "https://github.com/alecthomas/assert/")
+ (synopsis "Go assertion library")
+ (description "Assertion library that:
@itemize
@item makes spotting differences in equality much easier
@item uses repr and diffmatchpatch to display structural differences in colour
@item aborts tests on first assertion failure
-@end itemize\n")
- (license license:expat))))
+@end itemize")
+ (license license:expat)))
(define-public go-github-com-cheekybits-is
(let ((commit "68e9c0620927fb5427fda3708222d0edee89eae9")
@@ -189,6 +186,30 @@ style).
tests.")
(license license:expat)))
+(define-public go-github-com-go-test-deep
+ (package
+ (name "go-github-com-go-test-deep")
+ (version "1.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-test/deep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mmw2w3by7y24jjpjwmf2gfl08c65jihn3si9m0sswmagmdsk8q0"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-test/deep"))
+ (home-page "https://github.com/go-test/deep")
+ (synopsis "Human-friendly deep variable equality in Go")
+ (description
+ "The deep package provides the deep.Equal function which is like
+reflect.DeepEqual but returns a list of differences. This is helpful
+when comparing complex types like structures and maps.")
+ (license license:expat)))
+
(define-public go-github-com-golangplus-testing
(package
(name "go-github-com-golangplus-testing")
@@ -267,6 +288,28 @@ also update a file with new \"golden\" output that is deemed correct.")
values for the purpose of fuzz testing.")
(license license:asl2.0))))
+(define-public go-github-com-hexops-gotextdiff
+ (package
+ (name "go-github-com-hexops-gotextdiff")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hexops/gotextdiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vgq6w0cfhr76qlczgm5khsj1wnjkva0vhkh3qspaa1nkfw3jny1"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hexops/gotextdiff"))
+ (home-page "https://github.com/hexops/gotextdiff")
+ (synopsis "Unified text diffing in Go")
+ (description
+ "This package provides a library to generate unified diffs.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jacobsa-oglematchers
(let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
(revision "0"))
@@ -590,7 +633,9 @@ under test) much simpler.")
(file-name (git-file-name name version))
(sha256
(base32
- "033vv29g2wf6fd757ajfmha30bqin3b07377037zkl051mk6mghs"))))
+ "033vv29g2wf6fd757ajfmha30bqin3b07377037zkl051mk6mghs"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "examples"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/DATA-DOG/go-sqlmock"))
@@ -684,6 +729,23 @@ reformat the source code, it only prints out style mistakes.")
custom assertions to be used alongside native Go testing.")
(license license:expat)))
+(define-public go-github-com-go-playground-assert-v2
+ (package
+ (inherit go-gopkg-in-go-playground-assert-v1)
+ (name "go-github-com-go-playground-assert-v2")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-playground/assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13mb07dxhcy9ydqbracnrpfj682g6sazjpm56yrlbn2jc1yfy44c"))))
+ (arguments
+ (list #:import-path "github.com/go-playground/assert/v2"))))
+
(define-public go-honnef-co-go-tools
(package
(name "go-honnef-co-go-tools")