summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 15:34:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:43 +0100
commit977490e6350818c41085c710a3b90e31f8caea7f (patch)
treee3fe77d109ec5c03efe1652b8fee2dca724be427 /gnu/packages/golang-check.scm
parentc1ff8e9efcfac542ed15382a5afec4651ee81d06 (diff)
gnu: go-go-uber-org-goleak: Move to golang-check.
* gnu/packages/golang.scm (go-go-uber-org-goleak): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Iaadd6506457cb3487df8f27f71442a6dcabce816
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 2b70e8565f..3628b37b92 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 Fries <fries1234@protonmail.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
@@ -1002,6 +1003,33 @@ custom assertions to be used alongside native Go testing.")
(arguments
(list #:import-path "github.com/go-playground/assert/v2"))))
+(define-public go-go-uber-org-goleak
+ (package
+ (name "go-go-uber-org-goleak")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uber-go/goleak")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "go.uber.org/goleak"))
+ (native-inputs
+ (list go-github-com-stretchr-testify-next))
+ (home-page "https://go.uber.org/goleak")
+ (synopsis "Goroutine leak detector")
+ (description
+ "Go package to verify that there are no unexpected goroutines running at
+the end of a test.")
+ (license license:expat)))
+
(define-public go-honnef-co-go-tools
(package
(name "go-honnef-co-go-tools")