summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:08 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commitcf9c76223f028dce92bfe5b242a4faeba73f9d02 (patch)
tree0213814264f5967d42a2ea5e0b2ceb9f96bd8c57 /gnu/packages/golang-check.scm
parent18a537ec42f25b4497a42b905bacfd03fd30bbee (diff)
gnu: go-github-com-onsi-ginkgo: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-github-com-onsi-ginkgo): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index eb4f085bbf..ce4afe64ac 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
@@ -274,6 +275,37 @@ signalling failures, it offers ways to express expectations and get nice failure
messages automatically.")
(license license:asl2.0))))
+(define-public go-github-com-onsi-ginkgo
+ (package
+ (name "go-github-com-onsi-ginkgo")
+ (version "1.16.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/onsi/ginkgo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hh6n7q92y0ai8k6rj2yzw6wwxikhyiyk4j92zgvf1zad0gmqqmz"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/onsi/ginkgo"))
+ (propagated-inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-tools
+ go-github-com-go-task-slim-sprig
+ go-github-com-nxadm-tail
+ go-github-com-onsi-gomega))
+ (home-page "https://github.com/onsi/ginkgo")
+ (synopsis "BDD-style testing framework for Go")
+ (description
+ "Ginkgo is a Behaviour-Driven Development testing framework for Go. It
+builds on top of Go's builtin @code{testing} library and is complemented by the
+Gomega matcher library.")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(package
(name "go-github-com-stretchr-testify")