summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:10 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commitf6a03a8ba69ead8ab3bc39f9f750ac6d036c6b0b (patch)
tree76dce03d207ca9edce93fd5394167eebb3d5d7b3 /gnu/packages/golang-check.scm
parent4e65fb5b336197c0f20aba76ba8e44e9197a7a5b (diff)
gnu: go-golang-org-x-lint: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-golang-org-x-lint): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 011198231d..56f412224e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -458,6 +458,34 @@ such as readers and writers that fail after N consecutive reads/writes.")
custom assertions to be used alongside native Go testing.")
(license license:expat)))
+(define-public go-golang-org-x-lint
+ (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-lint")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/lint")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ms3rs5hvpnm9bxbr5f9743i7hn2bbmqdmvzxq6nmi0f24ypv1l3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/lint"
+ #:tests? #f)) ;; TODO: Fix tests
+ (propagated-inputs
+ (list go-golang-org-x-tools))
+ (home-page "https://golang.org/x/lint")
+ (synopsis "Linter for Go source code")
+ (description
+ "This is a linter for Go source code. Unlike gofmt, it doesn't
+reformat the source code, it only prints out style mistakes.")
+ (license license:bsd-3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar