summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commitfafa7e562e2f4070a938b919369f951852085bf5 (patch)
treed07611b6ce12ae600fe036092b1509a0e4ce97e1 /gnu/packages/golang-check.scm
parentc28b31964037beef27d79dab4a334400bd6937bd (diff)
gnu: Add go-github-com-chzyer-test.
* gnu/packages/golang-check.scm (go-github-com-chzyer-test): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ibbc266255bbc29737be3971516b5eef567a1175b
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index dd91bf23bc..7a3d9499ab 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2023 Fries <fries1234@protonmail.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
@@ -122,6 +123,36 @@
@end itemize\n")
(license license:expat))))
+(define-public go-github-com-chzyer-test
+ (package
+ (name "go-github-com-chzyer-test")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chzyer/test")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests relating to a in-memory disk fail due to a Segfault see
+ ;; <https://github.com/chzyer/test/issues/4>.
+ #:tests? #f
+ #:import-path "github.com/chzyer/test"))
+ (propagated-inputs
+ (list go-github-com-chzyer-logex))
+ (home-page "https://github.com/chzyer/test")
+ (synopsis "Testing library for Go")
+ ;; Description is not provided, see
+ ;; <https://github.com/chzyer/test/issues/3>.
+ (description
+ "A testing library for Go programs.")
+ (license license:expat)))
+
(define-public go-github-com-davecgh-go-spew
(package
(name "go-github-com-davecgh-go-spew")