summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:00:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:02 +0000
commite3942c7589966206d1d8b4246eddee753f1c4818 (patch)
treec44c41c0e0a1db01c996fd80bbafe441ea8f5e6b /gnu/packages/golang-crypto.scm
parent77a07a968fbeac49bffa5cb10d5eb7e004cc316b (diff)
gnu: Add (gnu packages golang-crypto) module.
* gnu/packages/golang-crypto.scm: New file. * gnu/local.mk: Add to gnu/packages/golang-crypto.scm scope. Change-Id: I92a110f31a74c5a54c59ee2a0f17373915be1b35
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
new file mode 100644
index 0000000000..38ccc5ffe9
--- /dev/null
+++ b/gnu/packages/golang-crypto.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages golang-crypto)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system go)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-check))
+
+;;; Commentary:
+;;;
+;;; Golang modules (libraries) related to Cryptography: encryption algorithms,
+;;; hashing functions, TLS, key management, digital signatures, password
+;;; hashing etc.
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;