summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:23:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commitea912634de767da0c3d890082c0b652d3a5fd1a3 (patch)
tree3c2b20b215095b508ba9f1dcd10859d1c45579d5 /gnu/packages/golang-crypto.scm
parent6dc9ac646183673d4b0684756e4661c8a24967d5 (diff)
gnu: go-github-com-quic-go-qtls-go1-20: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-quic-go-qtls-go1-20): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I28127466419cd798c926b62d160c6e512e5171bd
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 22593aff19..eac4fc8139 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
@@ -255,6 +256,33 @@ the Go standard library's TLS 1.3 implementation.")
(description "Multihash implementation in Go.")
(license license:expat))))
+(define-public go-github-com-quic-go-qtls-go1-20
+ (package
+ (name "go-github-com-quic-go-qtls-go1-20")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quic-go/qtls-go1-20")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fl3yv1w8cygag3lav45vvzb4k9i72p92x13wcq0xn13wxirzirn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/quic-go/qtls-go1-20"
+ #:go go-1.20))
+ (propagated-inputs
+ (list go-golang-org-x-crypto
+ go-golang-org-x-sys))
+ (home-page "https://github.com/quic-go/qtls-go1-20")
+ (synopsis "TLS 1.3 for QUIC")
+ (description "Go standard library TLS 1.3 implementation, modified for
+QUIC. For Go 1.20.")
+ (license license:expat)))
+
(define-public go-github-com-refraction-networking-utls
(package
(name "go-github-com-refraction-networking-utls")