summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:54:12 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:54:12 +0000
commit6f05c96f9635da7ca9f421d03a6359ff3b1d1a95 (patch)
tree9d1281865364a1e29822e1fae603eb7ab17cb9cd /gnu/packages/golang-crypto.scm
parent5b59c149e018e880f76407ec61df8d20ac063ece (diff)
gnu: go-github-com-bwesterb-go-ristretto: Move to golang-crypto.
* gnu/packages/golang.scm (go-github-com-bwesterb-go-ristretto): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: Ia028e4c5ccceaec3f0ceb828a147eff72cf6a20f
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 53ae308219..ceb1940ad9 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -261,6 +261,29 @@ been designed so it can be used as a standalone package for any projects
needing to use secp256k1 elliptic curve cryptography.")
(license license:isc))))
+(define-public go-github-com-bwesterb-go-ristretto
+ (package
+ (name "go-github-com-bwesterb-go-ristretto")
+ (version "1.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bwesterb/go-ristretto")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h508v790wk6g8jq0gh18296xl87vmgc4fhwnac7mk6i5g3mz6v4"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:unpack-path "github.com/bwesterb/go-ristretto"
+ #:import-path "github.com/bwesterb/go-ristretto/edwards25519"))
+ (home-page "https://github.com/bwesterb/go-ristretto")
+ (synopsis "Operations on the Ristretto prime-order group")
+ (description "This is a pure Go implementation of the group operations on
+the Ristretto prime-order group built from Edwards25519.")
+ (license license:expat)))
+
(define-public go-github-com-cespare-xxhash
(package
(name "go-github-com-cespare-xxhash")