summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:16:28 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit9ae4da0018557c690d6a177ab7cfda5feaaa1e75 (patch)
treef00ed58ba1410c4cdfe45fc9a8fa935095f7c9e2 /gnu/packages/golang-crypto.scm
parent4df431e6cb56c36c557c452c6005c336df731724 (diff)
gnu: go-github-com-operatorfoundation-ed25519: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-operatorfoundation-ed25519): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: Ia6a28bb8ad138b921e386f3b4d2dee65b43806d1
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 7216f63014..2b2e9d877f 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
@@ -521,6 +522,37 @@ Architecture Processors\" by J. Guilford et al.")
QUIC. For Go 1.20.")
(license license:expat)))
+(define-public go-github-com-operatorfoundation-ed25519
+ (let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
+ (revision "0"))
+ (package
+ (name "go-github-com-operatorfoundation-ed25519")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OperatorFoundation/ed25519")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xrzqrjlghkgd1cy5rj4khryn4f59vas2vzrxc6d8jpj5ijf3xkv"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/OperatorFoundation/ed25519"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'remove-test-data
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/testdata"))
+ #t)))))
+ (home-page "https://github.com/OperatorFoundation/ed25519")
+ (synopsis "Ed25519 for go")
+ (description "Package ed25519 implements the Ed25519 signature
+algorithm.")
+ (license license:bsd-3))))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")