summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 12:38:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:35:20 +0100
commiteef9ae4dbf98dfa1b667a2ccb455d7beae1a3b58 (patch)
tree69adde92dd7396159069eb2c7bac4957718c4d14 /gnu/packages/golang-crypto.scm
parentd2c92709cddc6cf00f53b1bb8b58409322b31a93 (diff)
gnu: Add go-github-com-gxed-hashland.
* gnu/packages/golang-crypto.scm (go-github-com-gxed-hashland): New variable. Change-Id: I260901efb4d8062d5a4ce24672156b70e64814a5
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 3b95965f6b..4f90ab4242 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -497,6 +497,39 @@ RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.")
#:go go-1.18
#:import-path "github.com/golang-jwt/jwt/v5"))))
+;; It's not public for purpose, as it contains a lot of golang modules which
+;; may be inherited from the single source, but the package itself does not
+;; have to be installed directly or linked to other packages..
+(define go-github-com-gxed-hashland
+ (package
+ (name "go-github-com-gxed-hashland")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gxed/hashland")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b921dh9i6zw7y8jfzwvrmdbhnwid12a5z1zjawslfq2vvsajwmm"))))
+ (build-system go-build-system)
+ ;; Source-only package.
+ (arguments
+ (list
+ #:tests? #f
+ #:import-path "github.com/gxed/hashland"
+ #:phases
+ #~(modify-phases %standard-phases (delete 'build))))
+ (home-page "https://github.com/gxed/hashland")
+ (synopsis "Collection of hash functions")
+ (description
+ "This package provides a source of Hashland - a collection of hash
+functions and functionality to test them. It aggregates various Golang
+libraries.")
+ (license license:expat)))
+
+;; TODO: Inherit from the go-github-com-gxed-hashland
(define-public go-github-com-gxed-hashland-keccakpg
(let ((commit "d9f6b97f8db22dd1e090fd0bbbe98f09cc7dd0a8")
(revision "0"))