summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:10:23 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commitf54ec8a59b400a4b93b5227f73b17a330fe19a08 (patch)
tree6a52c595d38fc677c06971a1be9bcce841668e22 /gnu/packages/golang-crypto.scm
parent2dd97bd8c5409c20611cc55c680f36a28048f38e (diff)
gnu: go-filippo-io-edwards25519: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-filippo-io-edwards25519): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/password-utils.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I11769b8b212bf4cbe98fe10181c0a2a479c599df
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 324e65c1ae..72771d40a2 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
@@ -40,6 +41,29 @@
;;;
;;; Code:
+(define-public go-filippo-io-edwards25519
+ (package
+ (name "go-filippo-io-edwards25519")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FiloSottile/edwards25519")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01m8hpaj0cwp250f7b0din09cf8j6j5y631grx67qfhvfrmwr1zr"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "filippo.io/edwards25519"))
+ (home-page "https://filippo.io/edwards25519")
+ (synopsis "Group logic for the twisted Edwards curve")
+ (description "This package implements the edwards25519 elliptic curve in
+Go, exposing the necessary APIs to build a wide array of higher-level
+primitives.")
+ (license license:bsd-3)))
+
(define-public go-github-com-aead-chacha20
(let ((commit "8b13a72661dae6e9e5dea04f344f0dc95ea29547")
(revision "0"))