summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:08:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commitc8640466e6bba3471d6418476c443f4a503bfddb (patch)
treead7ceffb3a3e115b9f5c9c61779fa5bd9100e569 /gnu/packages/golang-crypto.scm
parent65a2f158bbb3415abe83d454d2dc7235e65a77cc (diff)
gnu: go-github-com-flynn-noise: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-flynn-noise): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: Ie08a20d57424b0ce5fc10ced2a75b29c8aa3fe7d
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index c57c525a49..9fec753a35 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -223,6 +223,32 @@ Cryptography (ECC).")
messages.")
(license license:expat)))
+(define-public go-github-com-flynn-noise
+ (package
+ (name "go-github-com-flynn-noise")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flynn/noise")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j6phxyqx06wcqxjpin696fkp85s76qcp3i2f7fv6q2fb6618f6y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/flynn/noise"))
+ (propagated-inputs
+ (list go-gopkg-in-check-v1 go-golang-org-x-crypto))
+ (home-page "https://github.com/flynn/noise")
+ (synopsis "Go implementation of the Noise protocol framework")
+ (description "@code{noise} implements the Noise protocol framework. Noise
+is a low-level framework for building crypto protocols. Noise protocols
+support mutual and optional authentication, identity hiding, forward secrecy,
+zero round-trip encryption, and other advanced features.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gaukas-godicttls
(package
(name "go-github-com-gaukas-godicttls")