summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:26:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:28 +0100
commit294ad13de9b5f546839289c72ec37b2fcbdc472d (patch)
tree15de5235e21cf7c939f0aa06751c1f7efe3c9103 /gnu/packages/golang-web.scm
parent1abbcd2a65aead6e43c95fe921c109e3f9bafd3a (diff)
gnu: go-github-com-azure-go-ntlmssp: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-azure-go-ntlmssp): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I9c8397996470d84f57a4472717ebd0d06d06bb4c
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index eba37e3baf..2e9eaec388 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -437,6 +437,31 @@ for Go")
(description "This package provides a CSS parser and inliner.")
(license license:expat)))
+(define-public go-github-com-azure-go-ntlmssp
+ (package
+ (name "go-github-com-azure-go-ntlmssp")
+ (version "0.0.0-20211209120228-48547f28849e")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Azure/go-ntlmssp")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0im28kp9p6ncdmh7qq5qwl85nmiwmp8jka2qgrjiqzc5n36q56np"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/Azure/go-ntlmssp"))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (home-page "https://github.com/Azure/go-ntlmssp")
+ (synopsis "NTLM negotiation in Go")
+ (description
+ "This package provides NTLM/Negotiate authentication over HTTP.")
+ (license license:expat)))
+
(define-public go-github-com-bep-golibsass
(package
(name "go-github-com-bep-golibsass")