summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:36 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:24 -0500
commit3a3484bf5dd485b0a8ade2deb68368477eabca9c (patch)
treed6d290b7e8411fa230aa50dd553749ee0868c6b4 /gnu/packages/golang-web.scm
parent1371b119f3678e592c6aa03648df8bcd902dfeed (diff)
gnu: go-github-com-xeipuuv-gojsonpointer: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-xeipuuv-gojsonpointer): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I1c77a5a1b0e85fa57578ff29c9e3c403e4d62bc8
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 346ca87cc7..1f9fe0ffca 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1202,6 +1202,31 @@ sockets.")
replacement for native @code{net/http} module.")
(license license:expat)))
+(define-public go-github-com-xeipuuv-gojsonpointer
+ (let ((commit "4e3ac2762d5f479393488629ee9370b50873b3a6")
+ (revision "0"))
+ (package
+ (name "go-github-com-xeipuuv-gojsonpointer")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xeipuuv/gojsonpointer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13y6iq2nzf9z4ls66bfgnnamj2m3438absmbpqry64bpwjfbsi9q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/xeipuuv/gojsonpointer"))
+ (home-page "https://github.com/xeipuuv/gojsonpointer")
+ (synopsis "Implementation of JSON Pointer for Go")
+ (description
+ "This package provides an implementation of JSON Pointer for the Go
+programming language.")
+ (license license:asl2.0))))
+
(define-public go-github-com-xeipuuv-gojsonschema
(let ((commit "6b67b3fab74d992bd07f72550006ab2c6907c416")
(revision "0"))