summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:14 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:20 -0500
commit9a5946bc7aa56f541c374832c2e2ef08c25d19b9 (patch)
treecaea76bb03840d13bf66cbd6de56b0504da80b33 /gnu/packages/golang-web.scm
parent0ca7181c80d8d8d2ddd9741dd30fb19f87a2266f (diff)
gnu: go-github-com-emicklei-go-restful: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-emicklei-go-restful): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Idc88242d2ec3274a0b68244f5e91bbfc2dd8543c
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c501f55685..4cef7b6641 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
@@ -260,6 +261,29 @@ the parse trees produced by the html package.")
(list go-github-com-go-jose-go-jose-v3
go-golang-org-x-oauth2))))
+(define-public go-github-com-emicklei-go-restful
+ (package
+ (name "go-github-com-emicklei-go-restful")
+ (version "3.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emicklei/go-restful")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m1y5a6xr6hmdj77afrvyh2llkbhn1166lcrgis654shl8zs9qhz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emicklei/go-restful"))
+ (home-page "https://github.com/emicklei/go-restful")
+ (synopsis "Build REST-style web services using Go")
+ (description "This package provides @code{go-restful}, which helps
+developers to use @code{http} methods explicitly and in a way that's
+consistent with the HTTP protocol definition.")
+ (license license:expat)))
+
(define-public go-github-com-felixge-httpsnoop
(package
(name "go-github-com-felixge-httpsnoop")