summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:47 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:14 -0500
commite0060729b5dfa678bd686ad20435485a73f3d4d0 (patch)
tree4a911f4f3183d7d29ce1deef44fad12d9dba0996 /gnu/packages/golang-web.scm
parent13ab4abe98f1a88256d4ecd9b3ee3cb026515f4e (diff)
gnu: go-github-com-sourcegraph-jsonrpc2: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-sourcegraph-jsonrpc2): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/databases.scm: Add (gnu packages golang-web) module. Change-Id: Idda2e18ae5d3e19f72265bdd017eadddc25bcad9
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0ca70cec38..f9e7039707 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -208,6 +208,32 @@ protocol.")
to jQuery to the Go language.")
(license license:bsd-3)))
+(define-public go-github-com-sourcegraph-jsonrpc2
+ (package
+ (name "go-github-com-sourcegraph-jsonrpc2")
+ (version "0.1.0")
+ (home-page "https://github.com/sourcegraph/jsonrpc2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/sourcegraph/jsonrpc2"))
+ (propagated-inputs
+ (list go-github-com-daviddengcn-go-colortext
+ go-github-com-gorilla-websocket
+ go-github-com-motemen-go-colorine))
+ (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
+ (description
+ "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar