summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 20:41:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 20:49:00 +0000
commit560b4687e534836943f50ba5d56d779ddc1adeb0 (patch)
tree9fdc0a3d35a69ae71e0d0127cddf28db3eaa6c7b /gnu/packages/golang-web.scm
parentdf65af45b5f2cc76ce813ca91fab9054fd807bba (diff)
gnu: golang-web: Adjust module commentary.
Follow up <https://issues.guix.gnu.org/68835>. * gnu/packages/golang-web.scm: Mention sections for library and executable to reduce cross module inheritance. Change-Id: I9775d5681b380063dc43e6bd38aa94cec4f0db81
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 41626c9856..f11e59ce48 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -57,12 +57,18 @@
;;; Commentary:
;;;
;;; Golang modules (libraries) related to HTML, CSS, SCSS, JavaScript, JSON,
-;;; Web-framework, REST-API or similar functionality.
+;;; Web-framework, REST-API or similar functionality. They may provide
+;;; executables and libraries, for which there are marked sections.
+
;;;
;;; Please: Try to add new module packages in alphabetic order.
;;;
;;; Code:
+;;;
+;;; Libraries:
+;;;
+
(define-public go-cloud-google-com-go-compute-metadata
(package
(name "go-cloud-google-com-go-compute-metadata")
@@ -1518,6 +1524,10 @@ Signing and Encryption set of standards. This includes support for JSON Web
Encryption, JSON Web Signature, and JSON Web Token standards.")
(license license:asl2.0)))
+;;;
+;;; Executables:
+;;;
+
(define-public go-minify
(package
(inherit go-github-com-tdewolff-minify-v2)