summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorJesse Eisses <jesse@eisses.email>2024-04-26 10:01:51 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 15:38:27 +0100
commitbea3defe234354093bde1e44b1f6f1df88c5360e (patch)
tree93a776de099809aa2ffa223c1ef035d26de8c891 /gnu/packages/golang-web.scm
parente78fb8223f1ee8a68f5498040564870c1684a4d5 (diff)
gnu: Add go-github-com-pires-go-proxyproto.
* gnu/packages/golang-xyz.scm (go-github-com-pires-go-proxyproto): New variable. Change-Id: Iec8e8ead7e18cbbd9be00ec398d11e632e4b2ac4 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d0f51cfd79..f7de466619 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1564,6 +1564,36 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pires-go-proxyproto
+ (package
+ (name "go-github-com-pires-go-proxyproto")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pires/go-proxyproto")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p18w555xp187fl807h1yd092cvs8jarp98pa76zl84rxlk4k2h4"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/pires/go-proxyproto"))
+ (home-page "https://github.com/pires/go-proxyproto")
+ (synopsis "Implementation of the PROXY protocol")
+ (description
+ "Package proxyproto implements Proxy Protocol (v1 and v2) parser and
+writer, as per specification:
+@@url{https://www.haproxy.org/download/2.3/doc/proxy-protocol.txt}. It is to
+be used in one of or both proxy clients and proxy servers that need to support
+said protocol. Both protocol versions, 1 (text-based) and 2 (binary-based)
+are supported. @acronym{TLV, tag-length-value} parsers extensions comming with
+this library support AWS, Azure and GCP.")
+ (license license:asl2.0)))
+
(define-public go-github-com-pkg-sftp
(package
(name "go-github-com-pkg-sftp")