summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:15 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:20 -0500
commit75641bbd7398c8344450d54eeba035c0bbebdcaa (patch)
treee18fdbdf71766da853b6fdd8c4dff8584f2c80b4 /gnu/packages/golang-web.scm
parent9a5946bc7aa56f541c374832c2e2ef08c25d19b9 (diff)
gnu: go-github-com-tv42-httpunix: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-tv42-httpunix): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I1b81c93afd803dfd68fae5292cb2103855cdba6d
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4cef7b6641..caccb126bc 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -831,6 +832,30 @@ an interface to implement any other minifier.")
"This package contains several lexers and parsers written in Go.")
(license license:expat)))
+(define-public go-github-com-tv42-httpunix
+ (let ((commit "2ba4b9c3382c77e7b9ea89d00746e6111d142a22")
+ (revision "0"))
+ (package
+ (name "go-github-com-tv42-httpunix")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tv42/httpunix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xbwpip2hsfhd2kd878jn5ndl8y1i9658lggha4x3xb5m1rsds9w"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/tv42/httpunix"))
+ (home-page "https://github.com/tv42/httpunix")
+ (synopsis "Go library to talk HTTP over Unix domain sockets")
+ (description "This package is a Go library to talk HTTP over Unix domain
+sockets.")
+ (license license:expat))))
+
(define-public go-github-com-valyala-fasthttp
(package
(name "go-github-com-valyala-fasthttp")