summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:55 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:16 -0500
commit15593105894af86d86e627d136e5a3c5a791d2ea (patch)
treee6eb7657f6eef0735a713e4051a84c1860eb38d3 /gnu/packages/golang-web.scm
parent88b168ed27e48b2a45b0f27d2bfa0a6870d52a47 (diff)
gnu: go-github-com-jcmturner-dnsutils-v2: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-jcmturner-dnsutils-v2): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I65f87f8e8cd7970a15d3b1e09c5ef4202f0542db
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 580877f8fe..9b2bcd7cbd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -286,6 +286,34 @@ sessions, flash messages, custom backends, and more.")
protocol.")
(license license:bsd-2)))
+(define-public go-github-com-jcmturner-dnsutils-v2
+ (package
+ (name "go-github-com-jcmturner-dnsutils-v2")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/dnsutils")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "116zbgvfj88vv93fnapmmgyd5g8kzy774cdyzsnnzyzng92j61c9"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/dnsutils/v2"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/jcmturner/dnsutils")
+ (synopsis "Go library with DNS utils")
+ (description
+ "The dnsutils package provides a Go function to return a map of Service
+Records (SRV) in the order they should be used for a given service, protocol
+and name. The order is determined by the records' priority and randomized
+selection based on their relative weighting. This package is useful for
+network applications that require accessing services using SRV records.")
+ (license license:asl2.0)))
+
(define-public go-github-com-jcmturner-gokrb5-v8
(package
(name "go-github-com-jcmturner-gokrb5-v8")