summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:07 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:18 -0500
commit584bff22f27436c095a56560865cae05b31fbd84 (patch)
tree3546ad53be11e491d1ccf53eb1a59cd6420b9cb7 /gnu/packages/golang-web.scm
parent8a8b218b3fa963e078d63b38774539ee1cf9ae15 (diff)
gnu: go-gopkg-in-square-go-jose-v2: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-gopkg-in-square-go-jose-v2): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ifdc5b240c2f3af874d6b4b8b0422dfd9326348a3
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 72f2a7d84c..976179f44e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -683,6 +683,35 @@ an interface to implement any other minifier.")
"This package contains several lexers and parsers written in Go.")
(license license:expat)))
+(define-public go-gopkg-in-square-go-jose-v2
+ (package
+ (name "go-gopkg-in-square-go-jose-v2")
+ (version "2.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/square/go-jose")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b1nhqxfmhzwrfk7pkvp2w3z3d0pf5ir00vizmy2d4xdbnldn70r"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "gopkg.in/square/go-jose.v2"))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (native-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-stretchr-testify))
+ (home-page "https://gopkg.in/square/go-jose.v2")
+ (synopsis "Implementation of JOSE standards (JWE, JWS, JWT) in Go")
+ (description
+ "This package aims to provide an implementation of the Javascript Object
+Signing and Encryption set of standards. This includes support for JSON Web
+Encryption, JSON Web Signature, and JSON Web Token standards.")
+ (license license:asl2.0)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar