summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:24 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:22 -0500
commit31af3c2e3703202803927543a4473d4c0f56e6fc (patch)
treed12c9e6aabf19e24751ab569ed6b99e85caa8a41 /gnu/packages/golang-web.scm
parentae1d9ed08f9c45dd07b4429aebcb3cbd7b90116e (diff)
gnu: go-github-com-aws-aws-sdk-go: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-aws-aws-sdk-go): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ic639856afb340c2a7aea6dc917d2bcd32290d1b7
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1542c409fe..7ecdcbd8b5 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Adam Kandur <kefironpremise@gmail.com>
@@ -104,6 +105,33 @@ the parse trees produced by the html package.")
"This is the official AWS SDK for the Go programming language.")
(license license:asl2.0)))
+;; XXX: This package might be a duplicate of go-github-com-aws-sdk, it's not
+;; in use anywhere. Keep it here for the farther review.
+(define-public go-github-com-aws-aws-sdk-go
+ (package
+ (name "go-github-com-aws-aws-sdk-go")
+ (version "1.36.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-sdk-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "169mkkw1cff1px6326krwvfpfj07sb4y5rbn003gi4bk176h6ry9"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ (list go-github-com-jmespath-go-jmespath))
+ (arguments
+ '(#:import-path "github.com/aws/aws-sdk-go"
+ #:phases %standard-phases))
+ (synopsis "The official AWS SDK for the Go programming language")
+ (description
+ "The official AWS SDK for the Go programming language.")
+ (home-page "https://github.com/aws/aws-sdk-go")
+ (license license:asl2.0)))
+
(define-public go-github-com-aws-aws-sdk-go-v2
(package
(name "go-github-com-aws-aws-sdk-go-v2")