summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:34 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:24 -0500
commit65b1156d2b92bebacef1792615c85140c5ce41a3 (patch)
tree493b2efbf34e4c3981a76e9241033b49bee01ffc /gnu/packages/golang-web.scm
parentab7511ad0d29c74e464087e67081cc87836a9c09 (diff)
gnu: go-github-com-xeipuuv-gojsonschema: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-xeipuuv-gojsonschema): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Iaf68b653f279c98f62ce9e07f2ce010c8e1741e2
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4771657add..c97dfa7757 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1202,6 +1202,47 @@ sockets.")
replacement for native @code{net/http} module.")
(license license:expat)))
+(define-public go-github-com-xeipuuv-gojsonschema
+ (let ((commit "6b67b3fab74d992bd07f72550006ab2c6907c416")
+ (revision "0"))
+ (package
+ (name "go-github-com-xeipuuv-gojsonschema")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xeipuuv/gojsonschema")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q937a6q7canlr3dllqdw0qwa6z2fpwn1w9kycavx8jmwh6q3f69"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/xeipuuv/gojsonschema"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* "schema_test.go"
+ (("\\{\"phase\": \"remote ref, " all)
+ (string-append "// " all))
+ (("\\{\"phase\": \"valid definition" all)
+ (string-append "// " all))
+ (("\\{\"phase\": \"invalid definition" all)
+ (string-append "// " all)))))))))
+ (propagated-inputs
+ (list go-github-com-xeipuuv-gojsonreference
+ go-github-com-xeipuuv-gojsonpointer
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/xeipuuv/gojsonschema")
+ (synopsis "Implementation of JSON Schema for Go")
+ (description
+ "This package provides an implementation of JSON Schema for the Go
+programming language, which supports draft-04, draft-06 and draft-07.")
+ (license license:asl2.0))))
+
(define-public go-gopkg-in-square-go-jose-v2
(package
(name "go-gopkg-in-square-go-jose-v2")