summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:10 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:19 -0500
commit157369092adae975e2cd5f8f6e68f234e685900f (patch)
treea12b58a817d728f9c539897084af18c344bc75e6 /gnu/packages/golang-web.scm
parentcb523a9b6bce0332c796d4a2033d7d60a712a58b (diff)
gnu: go-github-com-aws-sdk: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-aws-sdk): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I8e82019c75b115548c2e0eea54b261ff8c3dd4a7
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0219ffb5e5..352c831e41 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -71,6 +71,34 @@
the parse trees produced by the html package.")
(license license:bsd-2)))
+(define-public go-github-com-aws-sdk
+ (package
+ (name "go-github-com-aws-sdk")
+ (version "1.35.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-sdk-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ky5lw2s2zpslnnqcs6hgsrwvwbxwgflb5jwf16dd4aga3vrg10c"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aws/aws-sdk-go/aws"
+ #:unpack-path "github.com/aws/aws-sdk-go"))
+ (propagated-inputs
+ (list go-github-com-go-sql-driver-mysql
+ go-github-com-jmespath-go-jmespath
+ go-github-com-pkg-errors
+ go-golang-org-x-net))
+ (home-page "https://github.com/aws/aws-sdk-go")
+ (synopsis "Library to access Amazon Web Services (AWS)")
+ (description
+ "This is the official AWS SDK for the Go programming language.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")