summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:32 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:23 -0500
commitba8babd9e74ab5692cfccc32f7dbafe9506a5002 (patch)
tree0d931e94de13fff754acdf95ce7d3a7441896d57 /gnu/packages/golang-web.scm
parentd0f3a60169ebb2505653afd588aea33ab02e8ca5 (diff)
gnu: go-github-com-nwidger-jsoncolor: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-nwidger-jsoncolor): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I924581a553c7b59b1be3e274a1845af68b438bcb
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 616a14fdf1..96873f020c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -934,6 +935,32 @@ router.")
(description "@code{bluemonday} is a HTML sanitizer implemented in Go.")
(license license:bsd-3)))
+(define-public go-github-com-nwidger-jsoncolor
+ (package
+ (name "go-github-com-nwidger-jsoncolor")
+ (version "0.3.0")
+ (home-page "https://github.com/nwidger/jsoncolor")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13rd146pnj7qm70r1333gyd1f61x40nafxlpvdxlci9h7mx8c5p8"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/nwidger/jsoncolor"))
+ (native-inputs
+ (list go-github-com-fatih-color))
+ (synopsis "Colorized JSON marshalling and encoding")
+ (description
+ "@code{jsoncolor} is a drop-in replacement for @code{encoding/json}'s
+@code{Marshal} and @code{MarshalIndent} functions and @code{Encoder} type
+which produce colorized output using github.com/fatih/color.")
+ (license license:expat)))
+
(define-public go-github-com-opentracing-opentracing-go
(package
(name "go-github-com-opentracing-opentracing-go")