summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorLuis Higino <luishenriquegh2701@gmail.com>2024-06-01 05:06:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:17:02 +0100
commit21d631a3e8034d9dd0d45d2b557350d85b6dfa8c (patch)
tree4a74f08afa0ab922ff63b2f02bc9707fd6efa4f4 /gnu/packages/golang-xyz.scm
parentca9fa4a88a4512a04fc3261e33e76eb509aa59eb (diff)
gnu: Add go-github-com-k0kubun-go-ansi.
* gnu/packages/golang-xyz.scm (go-github-com-k0kubun-go-ansi): New variable. Change-Id: I012a3b5c530f1fb7ee61e628fac216bdd966772c Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6355178c29..4408ff7d3e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1327,6 +1327,31 @@ Alphanum Algorithm} developed by Dave Koelle in Go.")
defined output to the standard output.")
(license license:expat)))
+(define-public go-github-com-k0kubun-go-ansi
+ (package
+ (name "go-github-com-k0kubun-go-ansi")
+ (version "0.0.0-20180517002512-3bf9e2903213")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k0kubun/go-ansi")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/k0kubun/go-ansi"))
+ (home-page "https://github.com/k0kubun/go-ansi")
+ (synopsis "Windows-portable ANSI escape sequence utility for Golang")
+ (description
+ "This library converts ANSI escape sequences to Windows API calls on
+Windows environment. You can easily use this feature by replacing fmt with
+ansi.")
+ (license license:expat)))
+
(define-public go-github-com-gabriel-vasile-mimetype
(package
(name "go-github-com-gabriel-vasile-mimetype")