summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 23:07:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 23:12:35 +0100
commit265452e1227161565d38fc5fedafe75ea26b800c (patch)
tree2ffe438f17e8527be296390db3f83b3482fd5e02 /gnu/packages/golang-xyz.scm
parent33a264496319a7dd0871bfc6fff6ab9aed0c66e4 (diff)
gnu: Add go-github-com-go-task-slim-sprig-v3.
* gnu/packages/golang-xyz.scm (go-github-com-go-task-slim-sprig-v3): New variable. Change-Id: I46ef3728993556dfc2d6c9349da6962d747e2664
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a613287dca..d4e04c9ebc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1421,6 +1421,26 @@ Slim-Sprig is a fork of Sprig that removes all external dependencies to make
the library more lightweight.")
(license license:expat))))
+(define-public go-github-com-go-task-slim-sprig-v3
+ (package
+ (inherit go-github-com-go-task-slim-sprig)
+ (name "go-github-com-go-task-slim-sprig-v3")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-task/slim-sprig")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h6m9n8w6yk0fp1kpk574kac6l3ibkh71myjakvns1nmqphb085w"))))
+ (build-system go-build-system)
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-go-task-slim-sprig)
+ ((#:import-path _) "github.com/go-task/slim-sprig/v3")))))
+
(define-public go-github-com-gobwas-glob
(package
(name "go-github-com-gobwas-glob")