summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:55 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commit48512de080203b11e2e4bdc5def1bacc40df6e04 (patch)
tree995db79093131ff0e1be2c69c8349a698c8000ee /gnu/packages/golang-xyz.scm
parente6efce9d4b760db544cfa0bd92bc6ab553d4b5f9 (diff)
gnu: Add go-github-com-karrick-godirwalk.
* gnu/packages/golang-xyz.scm (go-github-com-karrick-godirwalk): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I109086c8aeebb29015ece44e305a7f875b38b7b7
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d55bdf0be1..75384169e5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1546,6 +1546,29 @@ ABI}.")
customized globally.")
(license license:expat)))
+(define-public go-github-com-karrick-godirwalk
+ (package
+ (name "go-github-com-karrick-godirwalk")
+ (version "1.17.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karrick/godirwalk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jyvai5vpmx86l71hg9j6lxc2b4v32ajvcmjlz40zimfb9ip11q9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/karrick/godirwalk"))
+ (home-page "https://github.com/karrick/godirwalk")
+ (synopsis "Fast directory traversal library for Go")
+ (description
+ "This package provides functions to read and traverse directory trees.")
+ (license license:bsd-2)))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")