summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:55:26 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:08 +0000
commit714462744a25eccd6a5b77bccc7a032cc01698f8 (patch)
tree3c575ddf528446471ce633b9477aac7484a0e4c7 /gnu/packages/golang-xyz.scm
parent6d22865f583ac04a4166ce6cf07da586beb2500a (diff)
gnu: go-github-com-bitly-go-hostpool: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-bitly-go-hostpool): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ia314e6134f229c004f23d99a9c42dbd0adf105f8
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e3ecae5fe5..f324624f48 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -89,6 +89,31 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-bitly-go-hostpool
+ (package
+ (name "go-github-com-bitly-go-hostpool")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bitly/go-hostpool")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iibj7dwymczw7cknrh6glc6sdpp4yap2plnyr8qphynwrzlz73w"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/bitly/go-hostpool"))
+ (native-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/bitly/go-hostpool")
+ (synopsis "Pool among multiple hosts from Golang")
+ (description
+ "This package provides a Go package to intelligently and flexibly pool among
+multiple hosts from your Go application. Host selection can operate in round
+robin or epsilon greedy mode, and unresponsive hosts are avoided.")
+ (license license:expat)))
+
(define-public go-github-com-bitly-timer-metrics
(package
(name "go-github-com-bitly-timer-metrics")