summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:34:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:34:49 +0100
commit8ca2756e56fb625a5d90d73f0bcb87349ce54e80 (patch)
tree95d315d02c5cb2988d90c39b64b63d6fb9d81793 /gnu/packages/golang-xyz.scm
parent60e120da2293980b86b395d9f590c05381b09bd0 (diff)
gnu: go-github-com-mitchellh-colorstring: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I298ae2f0e94847ff865375120e4953d290bbe883
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ab2b74bc2c..cd945fe006 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2507,6 +2507,29 @@ Domain Name Service}. The API follows the less-is-more principle, by
presenting a small interface.")
(license license:bsd-3)))
+(define-public go-github-com-mitchellh-colorstring
+ (package
+ (name "go-github-com-mitchellh-colorstring")
+ (version "0.0.0-20190213212951-d06e56a500db")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/colorstring")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mitchellh/colorstring"))
+ (home-page "https://github.com/mitchellh/colorstring")
+ (synopsis "Functions to colorize strings for terminal output")
+ (description
+ "Colorstring provides functions for colorizing strings for terminal output.")
+ (license license:expat)))
+
(define-public go-github-com-modern-go-concurrent
(package
(name "go-github-com-modern-go-concurrent")