summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2024-02-11 19:28:23 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commitac9044699afa46bbb2c4220a700b03816a107065 (patch)
tree488edfe4d4e43c04189a2eb4a181c1942bfd6d0e /gnu/packages/golang-xyz.scm
parent9a938589d1bcc97cf82577d73c300c986ce59594 (diff)
gnu: Add go-github-com-skip2-go-qrcode.
* gnu/packages/golang-xyz.scm (go-github-com-skip2-go-qrcode): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I3510982cdbc7b540281c0b0f074c1cb140ce249b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dd08f19b92..186c0e87a3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -322,6 +322,27 @@ library which posts the metrics to the Prometheus client registry and just
updates the registry.")
(license license:asl2.0)))
+(define-public go-github-com-skip2-go-qrcode
+ (package
+ (name "go-github-com-skip2-go-qrcode")
+ (version "0.0.0-20200617195104-da1b6568686e")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skip2/go-qrcode")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pghd6y2x8a5fqy4rjn4d8j5jcslb236naycdza5an7vyvinsgs9"))
+ (patches (search-patches "go-github-com-skip2-go-qrcode-fix-tests.patch"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/skip2/go-qrcode"))
+ (home-page "https://github.com/skip2/go-qrcode")
+ (synopsis "QR code encoder")
+ (description "This package provides a QR code encoder for the Goloang.")
+ (license license:expat)))
+
(define-public go-github-com-songgao-water
(package
(name "go-github-com-songgao-water")