summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 21:32:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commitae60a953d61d6bd28adfa2f73fdbd37202039091 (patch)
treeace1d614dc81a035aab745bdf7625322e8a6d1b0 /gnu/packages/golang-xyz.scm
parentac9044699afa46bbb2c4220a700b03816a107065 (diff)
gnu: go-github-com-prometheus-client-model: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-prometheus-client-model): Move from here * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages golang-xyz) module. * gnu/packages/ipfs.scm: As above. * gnu/packages/networking.scm: As above. Change-Id: Ibf79be7fd49acc8fc88bf2411a4d7d89b44713d0
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 186c0e87a3..bdf29d64b4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
@@ -322,6 +323,36 @@ library which posts the metrics to the Prometheus client registry and just
updates the registry.")
(license license:asl2.0)))
+(define-public go-github-com-prometheus-client-model
+ (let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
+ (revision "2"))
+ (package
+ (name "go-github-com-prometheus-client-model")
+ (version (git-version "0.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_model")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zdmk6rbbx39cvfz0r59v2jg5sg9yd02b4pds5n5llgvivi99550"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/client_model"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
+ (propagated-inputs
+ (list go-github-com-golang-protobuf-proto))
+ (synopsis "Data model artifacts for Prometheus")
+ (description "This package provides data model artifacts for Prometheus.")
+ (home-page "https://github.com/prometheus/client_model")
+ (license license:asl2.0))))
+
(define-public go-github-com-skip2-go-qrcode
(package
(name "go-github-com-skip2-go-qrcode")