summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:02:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:17:03 +0100
commite76a755ecec948676e40ab233cfcbe6cd307c19f (patch)
tree4c6e1d326c0bf7be4dc8f57b9f65d4d9b8483025 /gnu/packages/golang-xyz.scm
parent02bb43b72282f1e1c68d70d87631a9028a0049b4 (diff)
gnu: Add go-github-com-tidwall-match.
* gnu/packages/golang-xyz.scm (go-github-com-tidwall-match): New variable. Change-Id: I6923c2383784aeaa45d432a92c4d05f55cd3bea0
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3722ddd2ce..bdad626368 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3462,6 +3462,29 @@ well as a program to generate applications and command files.")
storage system.")
(license license:bsd-2)))
+(define-public go-github-com-tidwall-match
+ (package
+ (name "go-github-com-tidwall-match")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tidwall/match")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n25md63xr5m66r6zc77n6fgcpv2ljrlk92ivp9hvp8xya22as9k"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tidwall/match"))
+ (home-page "https://github.com/tidwall/match")
+ (synopsis "Simple string pattern matcher for Golang")
+ (description
+ "Package match provides a simple pattern matcher with unicode support.")
+ (license license:expat)))
+
(define-public go-github-com-tidwall-pretty
(package
(name "go-github-com-tidwall-pretty")