summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2024-04-05 10:25:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit2fb3ff7e886cb725054a1058e034319c7bcfc9ab (patch)
tree75d27deb8c7f670ae0409993e61480f5284af358 /gnu/packages/golang-xyz.scm
parent037194373a9ebfab3829963b84854ece2f9fdc50 (diff)
gnu: Add go-github-com-modern-go-reflect2.
* gnu/packages/golang-xyz.scm (go-github-com-modern-go-reflect2): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I5cce2cac1cf535498bd5ecdd2d5db45080118947
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 50a8eab39c..1328083ef3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1869,6 +1869,29 @@ of @code{sync.Map} to Go versions below 1.9 and a cancellable Goroutine with
explicit ownership.")
(license license:asl2.0)))
+(define-public go-github-com-modern-go-reflect2
+ (package
+ (name "go-github-com-modern-go-reflect2")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/modern-go/reflect2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05a89f9j4nj8v1bchfkv2sy8piz746ikj831ilbp54g8dqhl8vzr"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/modern-go/reflect2"))
+ (home-page "https://github.com/modern-go/reflect2")
+ (synopsis "Cheaper reflect API")
+ (description
+ "This library provides a reflect api for Go programs
+without the runtime cost of the standard library reflect.Value.")
+ (license license:asl2.0)))
+
(define-public go-github-com-mreiferson-go-options
(package
(name "go-github-com-mreiferson-go-options")