summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-10-18 11:37:59 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:14:52 +0100
commit4d1079b9c91f470ad0046cf72428728c75d8a52a (patch)
tree6fe8b542138452f3a30177f2f885721628ab5f40 /gnu/packages/golang-xyz.scm
parentff5ef67110b6b4cf9dd165876ed53ece5b8514a7 (diff)
gnu: Add go-github-com-lestrrat-go-envload.
* gnu/packages/golang-xyz.scm (go-github-com-lestrrat-go-envload): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I6bdf0b026779556bf5a0a89de0c7e868f13c286d
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dfd4190a7d..649bd76a72 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1657,6 +1657,34 @@ word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license license:expat))))
+(define-public go-github-com-lestrrat-go-envload
+ (package
+ (name "go-github-com-lestrrat-go-envload")
+ (version "0.0.0-20180220234015-a3eb8ddeffcc")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lestrrat-go/envload")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hlhvygfg67w8pqmjl91124zggnz6m750vjmmjlf8ys63nv3na05"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/lestrrat-go/envload"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/lestrrat-go/envload")
+ (synopsis "Restore and load environment variables")
+ (description
+ "This package implements a Perl5 like @code{temporary} variable, for
+applications requiring reloading of configuration from environment variables
+or during the tests temporarily change the value of an environment variable in
+Golang.")
+ (license license:expat)))
+
(define-public go-github-com-lib-pq
(package
(name "go-github-com-lib-pq")