summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-05 21:10:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-05 21:11:02 +0100
commitb2dbd7ca8a9285ffd25c1bf089b0ffac28913997 (patch)
tree77dc31fb2da3a022855e2a10c0e20917f733b2c2 /gnu/packages/golang-xyz.scm
parent79c597c0ee27bc7ca7f5986ef71a90fb62e1422b (diff)
gnu: go-go-uber-org-atomic: Update to 1.11.0.
The upstream suggested to update to the latest version to resolve failing tests on RISK-V, see <https://github.com/uber-go/atomic/issues/164>. * gnu/packages/golang-xyz.scm (go-go-uber-org-atomic): Update to 1.11.0. [arguments]: <#:tests?>: Enable tests on all platforms. Change-Id: I6df21cfaebb9e4d4a609e93f3fe4bfea2bff5e8d
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4e40e148f2..3ff115dc2a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3251,7 +3251,7 @@ similar string with weeks or days too.")
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")
- (version "1.8.0")
+ (version "1.11.0")
(source
(origin
(method git-fetch)
@@ -3260,18 +3260,10 @@ similar string with weeks or days too.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0grswsk7nkf7zmmychf6aj6032shyag1kgs6zf7qwxyn55dym1v8"))))
+ (base32 "1jdp4gfv9jx7dd066wzj7cj6wsk7fb5q04is42xn2wyp80sw5k3p"))))
(build-system go-build-system)
(arguments
(list
- ;; XXX: Disable failing tests on non-x86-64 architecture, see
- ;; <https://github.com/uber-go/atomic/issues/164>.
- ;;
- ;; go.uber.org/atomic/uintptr_test.go:72:30: cannot convert
- ;; math.MaxUint64 (untyped int constant 18446744073709551615) to type
- ;; uintptr
- #:tests? (and (not (%current-target-system))
- (target-x86-64?))
#:import-path "go.uber.org/atomic"))
(native-inputs
(list go-github-com-stretchr-testify go-github-com-davecgh-go-spew))