summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:52 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commit701907fae9782e038cd949ed4d8c8d1581d58ac2 (patch)
tree1adf22f216049e65bc8b1080d34d9374858b6b53 /gnu/packages/golang-xyz.scm
parentb2ad18ce4d966ca7c12d7d9ca49556f5e88568b6 (diff)
gnu: Add go-github-com-dimchansky-utfbom.
* gnu/packages/golang-xyz.scm (go-github-com-dimchansky-utfbom): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I25ecf3bd881d2317b84ecaef5260c78296f51d56
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8df9481b0e..cbb7c394d8 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -417,6 +417,29 @@ of unit files.")))
metrics to Graphite.")
(license license:bsd-2)))
+(define-public go-github-com-dimchansky-utfbom
+ (package
+ (name "go-github-com-dimchansky-utfbom")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimchansky/utfbom")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ll3wqvifmdanfyg6wsvz31c7n4mnczg2yxb65j35qxrnak89hn3"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/dimchansky/utfbom"))
+ (home-page "https://github.com/dimchansky/utfbom")
+ (synopsis "Go Unicode byte order mark detection library")
+ (description
+ "This package provides a library for @acronym{BOM, Unicode Byte Order
+Mark} detection.")
+ (license license:asl2.0)))
+
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")